summaryrefslogtreecommitdiffhomepage
path: root/editor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'editor/CMakeLists.txt')
-rw-r--r--editor/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/editor/CMakeLists.txt b/editor/CMakeLists.txt
index aef82fec..8e96f92b 100644
--- a/editor/CMakeLists.txt
+++ b/editor/CMakeLists.txt
@@ -12,4 +12,8 @@ endif()
add_executable(${self} "${sources}" "${res}" "../loader/loader-impl.cpp")
target_link_libraries(${self} ${PROJECT_NAME}-main)
+if(FLOORMAT_PRECOMPILED-HEADERS)
+ target_precompile_headers(${self} PRIVATE precomp.hpp)
+endif()
+
install(TARGETS ${self} RUNTIME DESTINATION bin)