summaryrefslogtreecommitdiffhomepage
path: root/serialize/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'serialize/CMakeLists.txt')
-rw-r--r--serialize/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/serialize/CMakeLists.txt b/serialize/CMakeLists.txt
new file mode 100644
index 00000000..e695aff2
--- /dev/null
+++ b/serialize/CMakeLists.txt
@@ -0,0 +1,5 @@
+find_package(nlohmann_json QUIET REQUIRED)
+set(self "${PROJECT_NAME}-serialize")
+link_libraries(Magnum::Magnum nlohmann_json::nlohmann_json)
+file(GLOB sources "*.cpp" CONFIGURE_ARGS)
+add_library(${self} STATIC ${sources})