summaryrefslogtreecommitdiffhomepage
path: root/eigen/doc/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2019-03-03 21:09:10 +0100
committerStanislaw Halik <sthalik@misaki.pl>2019-03-03 21:10:13 +0100
commitf0238cfb6997c4acfc2bd200de7295f3fa36968f (patch)
treeb215183760e4f615b9c1dabc1f116383b72a1b55 /eigen/doc/examples/CMakeLists.txt
parent543edd372a5193d04b3de9f23c176ab439e51b31 (diff)
don't index Eigen
Diffstat (limited to 'eigen/doc/examples/CMakeLists.txt')
-rw-r--r--eigen/doc/examples/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/eigen/doc/examples/CMakeLists.txt b/eigen/doc/examples/CMakeLists.txt
deleted file mode 100644
index f7a1905..0000000
--- a/eigen/doc/examples/CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-file(GLOB examples_SRCS "*.cpp")
-
-foreach(example_src ${examples_SRCS})
- get_filename_component(example ${example_src} NAME_WE)
- add_executable(${example} ${example_src})
- if(EIGEN_STANDARD_LIBRARIES_TO_LINK_TO)
- target_link_libraries(${example} ${EIGEN_STANDARD_LIBRARIES_TO_LINK_TO})
- endif()
- add_custom_command(
- TARGET ${example}
- POST_BUILD
- COMMAND ${example}
- ARGS >${CMAKE_CURRENT_BINARY_DIR}/${example}.out
- )
- add_dependencies(all_examples ${example})
-endforeach(example_src)
-
-check_cxx_compiler_flag("-std=c++11" EIGEN_COMPILER_SUPPORT_CPP11)
-if(EIGEN_COMPILER_SUPPORT_CPP11)
-ei_add_target_property(nullary_indexing COMPILE_FLAGS "-std=c++11")
-endif() \ No newline at end of file