summaryrefslogtreecommitdiffhomepage
path: root/tracker-kinect-face/CMakeLists.txt
diff options
context:
space:
mode:
authorStéphane Lenclud <github@lenclud.com>2019-03-19 21:25:32 +0100
committerGitHub <noreply@github.com>2019-03-19 21:25:32 +0100
commitf0eecc4ee2d7a340bf96571cf626bde27c91542c (patch)
treeec5de180c94cc5d97ce0343a5613146dcdc0170d /tracker-kinect-face/CMakeLists.txt
parenta0364ef52874ae3e072d81001c435219f0e5cc76 (diff)
Kinect support for Point Tracker (#914)
Kinect tracker now provides IR camera for Point Tracker to use. Closes #914
Diffstat (limited to 'tracker-kinect-face/CMakeLists.txt')
-rw-r--r--tracker-kinect-face/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/tracker-kinect-face/CMakeLists.txt b/tracker-kinect-face/CMakeLists.txt
index 8eb064e7..7d8f828a 100644
--- a/tracker-kinect-face/CMakeLists.txt
+++ b/tracker-kinect-face/CMakeLists.txt
@@ -40,5 +40,16 @@ if (WIN32 AND opentrack-intel)
DESTINATION "${opentrack-hier-pfx}"
PERMISSIONS ${opentrack-perms-exec}
)
+
+ # Optional OpenCV support
+ # Needed for Point Tracker to support Kinect V2 IR Sensor
+ find_package(OpenCV QUIET)
+ if(OpenCV_FOUND)
+ add_definitions(-DOTR_HAVE_OPENCV)
+ target_include_directories(${self} SYSTEM PUBLIC ${OpenCV_INCLUDE_DIRS})
+ target_link_libraries(${self} opencv_imgproc opentrack-cv opencv_core opentrack-video)
+ endif()
+
+
endif()
endif()