summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2023-12-01 09:40:09 +0100
committerStanislaw Halik <sthalik@misaki.pl>2023-12-01 09:40:19 +0100
commitdd89a8170ac667aff4e1f18b1ac641eb76e5b6ee (patch)
tree7e95cdcd110288540b98a57f6801fb5241ff6ba1 /CMakeLists.txt
parentb025c445ec226a279f7ec5d56ac320a0d53bf2cf (diff)
aa
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c39a6e0b..515a696b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,6 +113,7 @@ endif()
if(NOT APPLE AND NOT WIN32)
add_compile_options(-fno-plt)
add_link_options(-Wl,-z,relro,-z,now)
+ add_link_options(-Wl,-z,nodlopen -Wl,-z,noexecstack)
endif()
add_definitions(