summaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c39a6e0b..515a696b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,6 +113,7 @@ endif()
if(NOT APPLE AND NOT WIN32)
add_compile_options(-fno-plt)
add_link_options(-Wl,-z,relro,-z,now)
+ add_link_options(-Wl,-z,nodlopen -Wl,-z,noexecstack)
endif()
add_definitions(