summaryrefslogtreecommitdiffhomepage
path: root/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislaw Halik <sthalik@misaki.pl>2019-05-05 12:34:01 +0200
committerStanislaw Halik <sthalik@misaki.pl>2019-05-06 03:42:13 +0200
commit6eda8a85b84c4e661a8763429ae1978f8da7f9dd (patch)
tree5169e1bf6779f7442235f36a206a91e224cda05d /video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt
parent12dfd6dcf60d9fefef7f8723fb9bc5a21fdb5b61 (diff)
video/ps3eye: WIP
Diffstat (limited to 'video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt')
-rw-r--r--video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt b/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt
new file mode 100644
index 00000000..5064b2d8
--- /dev/null
+++ b/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(cmake-modules "${CMAKE_CURRENT_LIST_DIR}/cmake/")
+if(MSVC)
+ set(CMAKE_MODULE_PATH "${cmake-modules}" ${CMAKE_MODULE_PATH})
+else()
+ list(APPEND CMAKE_MODULE_PATH "${cmake-modules}")
+endif()
+
+find_package(SDL2 QUIET)
+if(SDL2_FOUND)
+ include_directories(${SDL2_INCLUDE_DIRS})
+ link_libraries(${SDL2_LIBRARIES})
+ link_libraries(opentrack-ps3eye)
+ otr_module(ps3eye-test EXECUTABLE NO-QT WIN32-CONSOLE)
+ if(WIN32)
+ foreach(k ${SDL2_LIBRARIES})
+ get_filename_component(path "${k}" PATH)
+ set(lib "${path}/SDL2.dll")
+ if(EXISTS "${lib}")
+ otr_install_lib("${lib}" "${opentrack-hier-pfx}")
+ break()
+ endif()
+ endforeach()
+ endif()
+endif()