summaryrefslogtreecommitdiffhomepage
path: root/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt')
-rw-r--r--video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt b/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt
new file mode 100644
index 00000000..5064b2d8
--- /dev/null
+++ b/video-ps3eye/PS3EYEDriver/sdl/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(cmake-modules "${CMAKE_CURRENT_LIST_DIR}/cmake/")
+if(MSVC)
+ set(CMAKE_MODULE_PATH "${cmake-modules}" ${CMAKE_MODULE_PATH})
+else()
+ list(APPEND CMAKE_MODULE_PATH "${cmake-modules}")
+endif()
+
+find_package(SDL2 QUIET)
+if(SDL2_FOUND)
+ include_directories(${SDL2_INCLUDE_DIRS})
+ link_libraries(${SDL2_LIBRARIES})
+ link_libraries(opentrack-ps3eye)
+ otr_module(ps3eye-test EXECUTABLE NO-QT WIN32-CONSOLE)
+ if(WIN32)
+ foreach(k ${SDL2_LIBRARIES})
+ get_filename_component(path "${k}" PATH)
+ set(lib "${path}/SDL2.dll")
+ if(EXISTS "${lib}")
+ otr_install_lib("${lib}" "${opentrack-hier-pfx}")
+ break()
+ endif()
+ endforeach()
+ endif()
+endif()